Bad ignition switch? 92 GL1500. - Page 4 - Steve Saunders Goldwing Forums

 1Likes
Closed Thread
 
LinkBack Thread Tools
post #31 of 31 (permalink) Old 07-26-2016, 06:12 PM
Senior Member
 
Join Date: Oct 2006
Location: Green Bay, Wisconsin, USA
Year: 1999
Make: GL1500 SE
Posts: 5,543
You're too fast Dave. I had the wrong book. The 91 wing is different. See above.

Mike

Worked on the "big rigs" for 45 years now just riding my Wing whenever I can. Gets cold in Wisconsin.
redwing52 is offline  
Sponsored Links
Advertisement
 
Closed Thread

  Steve Saunders Goldwing Forums > Forums > Goldwing Technical Forum

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Steve Saunders Goldwing Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
GL1200 1984 bad Ignition switch robertbynum Goldwing Technical Forum 23 12-19-2012 08:16 PM
GL1500 Ignition switch Square Shooter Goldwing Technical Forum 7 07-05-2012 12:05 PM
Ignition switch removal, GL1500 dan3071 Goldwing Technical Forum 5 04-13-2012 05:42 PM
no dash lights...bad ignition switch? JAinPA Goldwing Technical Forum 7 06-13-2006 08:02 PM
Bad Ignition Switch Wingin It Gene Goldwing Technical Forum 5 07-25-2005 12:11 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome