Steve Saunders Goldwing Forums - Search Results

Advanced Search
Showing results 1 to 7 of 7
Search took 0.17 seconds.
Search: Posts Made By: johnny42
Forum: Goldwing Technical Forum   04-28-2019, 09:45 PM
Replies: 12
Views: 456
Posted By johnny42
Thanks a bunch guys. I happened to have a flat...

Thanks a bunch guys. I happened to have a flat sharpening stone and went to work on the deposits on the bike side and the cover piece. I could not get rid of the discoloration but I am satisfied...
Forum: Goldwing Technical Forum   04-28-2019, 11:29 AM
Replies: 12
Views: 456
Posted By johnny42
Here's photos. Acetone did not touch the stuff...

Here's photos. Acetone did not touch the stuff on the bike side. I think the cover side is clean now. I'd rather use a chemical remover instead of a mechanical remover so as not to "deform" the...
Forum: Goldwing Technical Forum   04-21-2019, 10:58 PM
Replies: 12
Views: 456
Posted By johnny42
Water pump cover questions

When I removed the cover, it appears as if the last mechanic that touched this used some sort of sealer at this connection. The O-Ring seemed flat (I suspect he did not use a new one) and the...
Forum: Goldwing Technical Forum   04-20-2019, 04:31 PM
Replies: 10
Views: 448
Posted By johnny42
Thanks for the input all. Before quitting for...

Thanks for the input all. Before quitting for the day yesterday, I removed the coil and placed the hose properly which was easy. Today, I decided to try it again with the coil on. Boom! All good....
Forum: Goldwing Technical Forum   04-19-2019, 07:21 PM
Replies: 10
Views: 448
Posted By johnny42
Radiator hose sleeves / coils

Replacing my radiator hoses (Napa 7733) on my 1983 GL1100 Interstate (original 36 year old ones). They have these steel coil wraps that slip on and off. I can not get the upper hose onto the water...
Forum: Goldwing Technical Forum   04-23-2011, 11:39 PM
Replies: 5
Views: 585
Posted By johnny42
Post imported post

Same exact thing happened with me a couple weeks ago during my NY State inspection. Did you actually open up the switch or just clean it and the little plunger? It seems to work just doing that. It...
Forum: New Members Introduction Forum   04-10-2010, 02:40 PM
Replies: 19
Views: 520
Posted By johnny42
Post imported post

I'm new here. Still have my '83 Interstate I bought new. I joined to pick brains initially as I need new tires. The date code on the current ones are from 2000 and 2001, but the treads are still...
Showing results 1 to 7 of 7

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome