Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Premium Member
Joined
·
272 Posts
Discussion Starter · #1 ·
imported post

i had 10w30 oil in my 1200 but i could hee my valves clicking a bit so i decided to put in 15w40 . now my valves click even more than before.

what should i use to get rid of the clicking noise?
 

·
Premium Member
Joined
·
272 Posts
Discussion Starter · #9 ·
imported post

thanks for all the answers,the thing is i didnt hear or almost no ticking before i changed my oil to 15w40. guess ill just go back to 10w30.by the way handyman was that post talking about the spark plug wiring or the whole motorcycle wiring?
 

·
Premium Member
Joined
·
272 Posts
Discussion Starter · #11 ·
imported post

its actually pretty warm over here theses days,would 5w40 be a little too thin oil ?
 

·
Premium Member
Joined
·
272 Posts
Discussion Starter · #14 ·
imported post

ill take your word for it gary, ill go and buy some this afternoon and try it
thanks.
im tired of the clicking sound ...lol
 

·
Premium Member
Joined
·
272 Posts
Discussion Starter · #16 ·
imported post

id love to use that stuff dusty, but seafoam is not available here in quebec canada
 

·
Premium Member
Joined
·
272 Posts
Discussion Starter · #22 ·
imported post

well ! i put back some new 10w30 castrol gtx this morning and it seems to have solved the problem of clicking .
ill go for a ride tonight to see the difference
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top