Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Premium Member
Joined
·
3,795 Posts
Discussion Starter · #1 ·
I ordered a new LCD assembly thinking they would all interchange & found out they won't. My wiring harness has a 20 pin plug & teh new one has a 10 pin & a 14 pin plug. I got the wiring harness from a site member & don't remember what year he said it was from. Anybody know what year assembly I need? Thanks, Andy.
 

·
Premium Member
Joined
·
1,091 Posts
Lope, I don't know the answer to your question but I think if you looked at OEM fiche pictures you could figure it out.
 

·
Premium Member
Joined
·
75 Posts
If its just that your LCD that is defective you can just swap out the display portion. Been there and done it. Much wiser than messing with the plugs.
 

·
Premium Member
Joined
·
3,795 Posts
Discussion Starter · #4 ·
The fiche is the same for all the years, one of the few times Honda didn't change something every year. Didn't have a video screen to change, upgraded form an Interstate to a SE so had to change out the instrument panel. I ordered a display to fit a 2000 but it's plug has a 10 pin & a 14 pin plug. My harness has a 20 pin plug. Wondering if switching the wires from the new to the old would work or do I need to get in touch with a warehouse & have someone verify which part I need.
 

·
Administrator
Joined
·
27,936 Posts
do I need to get in touch with a warehouse & have someone verify which part I need.

:ROFL::ROFL::ROFL: Good luck with that. :ROFL:
 

·
Premium Member
Joined
·
3,795 Posts
Discussion Starter · #6 ·
Yeah I know Dave, but a guy can dream. Figured out where I got the wiring harness & sent a PM. Maybe he can remember what year the harness was.
 

·
Premium Member
Joined
·
1,091 Posts
Call Western Honda. They'll figure it out for you.
 

·
Premium Member
Joined
·
3,795 Posts
Discussion Starter · #8 ·
Well I'm a nimrod! After going back out to the garage in the daylight & not thinking I needed to rush I took a better look & it will work. Have the meter cluster back in, will ops check it in a bit.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top