Steve Saunders Goldwing Forums banner

1 - 14 of 14 Posts

·
Registered
Gl1500 1992
Joined
·
39 Posts
Discussion Starter · #1 ·
Hi all, my speedo clock has stopped working so easiest fix is replace the unit £££££. cheaper option is opening the housing and replacing the speedo clock. My question is how to open it up and replace. The speedo cable has been replaced as the previous one snapped, drive gear has been checked and is turning the cable so guess its the speedo clock. Any help gratefully appreciated. My bike is a 1500gl 1992. Would older/younger models fit as well?
 

·
Registered
Joined
·
566 Posts
Worth checking cable again especially if it was aftermarket as i fitted 2 in a month to my mates trike, genuine one 2nd time and still going strong 1 yr later
 

·
Registered
Gl1500 1992
Joined
·
39 Posts
Discussion Starter · #3 ·
Thanks for your reply, fitted aftermarket when it stopped working, no response so fitted a genuine Honda and still no result, have just finished stripping the clock and spraying anti degrease over the working parts and all ok👍 just needed a good clean 👌
 

·
Premium Member
Joined
·
117 Posts
I don't understand "clock"
 

·
Registered
Joined
·
8 Posts
Check speedometer gear at the front axle.Get front wheel off the ground and spin it. Do you see the gear moving without the cable on it?
 

·
Registered
Gl1500 1992
Joined
·
39 Posts
Discussion Starter · #8 ·
Hi thanks for your advice, speedometer working with Honda cable and internals of speedometer cleaned, spun the wheel and no response on the speedo. Will remove the wheel and update later in the week. Many thanks andy
 

·
Registered
Joined
·
566 Posts
Not surewhat you mean is thespeed needle movingand not the miles counter or vice versa or nothing?
 

·
Registered
Gl1500 1992
Joined
·
39 Posts
Discussion Starter · #10 ·
Hi ya nothing was moving but have traced it to the speed sensor, speedometer working with cable attached and drill to test, spinning the wheel has no response or test ride so new sensor it is. Thanks for your response. Andy
 

·
Registered
Gl1500 1992
Joined
·
39 Posts
Discussion Starter · #12 ·
Not got it off yet so hoping it just needs cleaning and re greasing. Any knowledge about these??
 

·
Pwhoever
Joined
·
3,292 Posts
There is a plastic gear on there that strips out quite often and will probably need to be replaced. That's probably what is going to be your issue. You should be able to tell once you have the speedo gear housing off.

Part #44806-MT2-003

325804
 

·
Registered
Gl1500 1992
Joined
·
39 Posts
Discussion Starter · #14 ·
Speed sensor removed, cleaned and greased, refitted and spun the wheel... Nothing! Went for a test run and after 20 minutes speedo needle started working!! Can only assume after a long time not riding the needle became stuck. All OK now.
 
1 - 14 of 14 Posts
Top