Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Premium Member
Joined
·
63 Posts
Discussion Starter · #1 ·
imported post

I have a 2006 1800 and the radio is just not very good, I can pick up some FM stations, sometimes, but virtually noAM stations. Is this typical or do I have a problem?



Also, my owners manual says the oil capacity with filter is four quarts. The first time I changed the oil and filter I put in four quarts and the dip stick indicated I hade way too much. The next time I added about 3.3 quarts and it appears to be perfect on the dip stick. What's up?
 

·
Premium Member
Joined
·
658 Posts
imported post

This is probably better in the tech support forum, but I'll address the oil issue:

when you changed oil, did you have it on the side stand or the center stand? It sounds to me like you are not getting it all drained. The center stand would be ideal. My 1800 takes 4 quarts dead on the money.

The other thought might be that you are screwing the dipstick all the way in to check it. If so you will show too full. Check the oil by inserting the dipper to start of the threads.
 

·
Premium Member
Joined
·
3,403 Posts
imported post

It is also important to run the engine a few minutes after changing the oil, then shut it down and let it settle.

That oil has to get in to all sorts of places which it can only do when running.

And as bbach says, put the dipstick in to the start of the threads, and the bike MUST be on the centre stand.
 

·
Premium Member
Joined
·
3,403 Posts
imported post

As for the radio, I think you have a problem, I find the reception on mine to be excellent. The only things I can think of to check are the antenna connections, there is one under the top shelter in to the radio unit, I think it is hardwired at the antenna end, you could also check the connector for the amp which is under the seat.

If by any chance it is still under warranty, go see the dealer!!!!
 

·
Administrator
Joined
·
27,898 Posts
imported post

I put 4 US quarts in mine and it shows just a little low.

I'm with English Bob on the antenna connections.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top