Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Premium Member
Joined
·
2 Posts
Discussion Starter #1
imported post

The Honda Clarion radio has quit working on my 1982 GL 1100A. I just get static through the speakers. The green stereo light doesn't come on either. What gives?
 

·
Administrator
1987 GL1200 Interstate
Joined
·
22,937 Posts
imported post

Hi Jetstream, welcome to the forum.

Sounds like the antenna.Is that radio removable? If so, gunk or corrosion onthe connection at the mount would be my first guess. If that's good,trace the wire looking for a dirty, broken or loose connection.
 

·
Premium Member
Joined
·
2,048 Posts
imported post

There are three connectors in the antenna coax on your bike. First one is at the bottom of the antenna, second is under the storage box on the left side of the fairing and the last one is under the storage box on the right side where it plugs into the receiver. If these are all good, you might want to give Sierra Electronics a call. They still repair these old radios and are very helpful.
 

·
Premium Member
Joined
·
503 Posts
imported post

you can call sierra electronics and talk to a tech.937-335-8939.they found a cracked board in mine.fixed it now works like new...



remember radio is on right side underfarring pocket.i allwaysthought that radio was on the left side.but that is the controler.
 

·
Premium Member
Joined
·
2 Posts
Discussion Starter #5
imported post

Thanks to all who have replied so far. It gives me something to start on. The green stereo light does come on briefly, it just doesn't stay on. It flickers and that's it. I won't get a chance to work on the bike until after work tomorrow evening.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top