Steve Saunders Goldwing Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I've owned this bike for 6 years. No issues ever until today. Rode about 15 miles and dropped something off at a friends. Hoped back on the bike to go run some other errands. Turned key on and hit start. Starter bumped for a second then nothing. At first I thought I needed to clean the connections. Clean battery connections and still no power to key. No lights to dash. Neutral oil light ect. Turn signals not working ect. checked fuse at the solenoid and it's good. Ideas?
 

·
Administrator
Joined
·
27,758 Posts
Check the connector on top of the solenoid And if OK try shorting across the fuse or just replace it, they can be cracked and look just fine.
 
  • Like
Reactions: Bike...and Dennis

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
So did not spend much time with it the other day but have since. I believe it's the key switch. On accessory my radio comes on, but when I move to the on position radio goes off. My question then is can I put my old tumblers in the new key switch so the key remains the same?
 

·
Administrator
Joined
·
27,758 Posts
So did not spend much time with it the other day but have since. I believe it's the key switch. On accessory my radio comes on, but when I move to the on position radio goes off. My question then is can I put my old tumblers in the new key switch so the key remains the same?
If you can get it apart probably so, I don't remember trying to do that.
 

·
Premium Member
1993 gl1500, 1976 gl1000
Joined
·
3,880 Posts
1 - 8 of 8 Posts
Top