Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Premium Member
Joined
·
3 Posts
Discussion Starter · #1 ·
imported post

Coming home from work today I lost the digital speedometer on my 84 aspencade the dash is working but mph reads {0} and the analog clock{odo} does not move.

Is the analog actually controlled by the pick up at the front wheel as well as the digital dash? I had the front wheel off but that was many hundred miles ago. It just quit. Any easy solutions out there? Thanks Dave Klatt [email protected]
 

·
Premium Member
Joined
·
5,713 Posts
imported post

There is a small motor that works the odometer that is plugged into the circuit board behind the LCD module. I would think that the sending unit down at the wheel sends the signal to the digital speedometer, in turn sends the signal to the odometer motor.



We just got through changing the LCD unit out on my Dad's 1200. Speedometer worked, but odometer didn't. I had to buy a whole dash unit off e-bay to get the little motor we needed.



You may be luck enough that it is the sending unit on the front wheel, I have no idea how you would test it.:?
 

·
Premium Member
Joined
·
659 Posts
imported post

Any ideas about missing segments then,,, they come and go !

it's a 1984 ASPY GL1200A


Thankks Loads

b679995
 

·
Administrator
1987 GL1200 Interstate
Joined
·
23,273 Posts
imported post

Hi Dave,

If the whole thing quit all at once, I'd say you have something electrical going on. Maybe something just came unplugged. Do you have the tools and ability to test the continuity in the system? You can start at the wheel since it's the easiest to get to, and most recently disturbed.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top