Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Premium Member
Joined
·
593 Posts
Discussion Starter #1
imported post

On my 85 the brake light works with the front brake but not when I use the foot brake.



Best things to check ? The bike has 6800 miles and has probably never been wet so I'm



thinking it isn't the switch but you never know. Thanks, John
 

·
Premium Member
Joined
·
46 Posts
imported post

I would check the switch, it should be pretty easy to do. I remember having problems on mine, but don't have the bike anymore to look at and remember what I did.
 

·
Still Learning
Joined
·
13,270 Posts
imported post

Try pulling on the brake spring while the pedal is depressed, if the light works adjust the nut on the switch.
 

·
Premium Member
Joined
·
1,522 Posts
imported post

take wire of swich or connector. touch a wire to both connections on the wires or connector and see if brake light comes on.. If it does, its your switch. 9 times outta ten its the switch.
 

·
Premium Member
Joined
·
593 Posts
Discussion Starter #5
imported post

newday777 wrote:
Try pulling on the brake spring while the pedal is depressed, if the light works adjust the nut on the switch.


Sheesh you guys are quick ! Yes I did that on my own and figured it out but thanks just the same. This is one awsome place, thank you all ! John
 

·
Registered
Joined
·
1 Posts
good day have been reworking a 1984 gl1200 almost ready to ride thanks to a lot of post here however I now have a dash light that says tail light checked and have no brake light with foot pedal but have it with hand brake. Do have a bad switch or would adjusting foot brake cable fix my problem thanks in advance
 

·
Administrator
1987 GL1200 Interstate
Joined
·
22,757 Posts
good day have been reworking a 1984 gl1200 almost ready to ride thanks to a lot of post here however I now have a dash light that says tail light checked and have no brake light with foot pedal but have it with hand brake. Do have a bad switch or would adjusting foot brake cable fix my problem thanks in advance
Hi Chance, welcome to the forum.
You really should put up a new thread on this, but since we are here already...
This sounds like two different issues. The dash light indicates a problem with the tail lights themselves. Could be a burned out bulb or some corrosion somewhere in the circuit. Or maybe someone just put a non-spec bulb in the system.
For the brake light, it's probably just the switch down on the right side of the bike. Those often get dirty or just go out of adjustment.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top