Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Premium Member
Joined
·
11 Posts
Discussion Starter #1
imported post

I have seen a few post with problems on the turn signals but don't sound like the same problem I’m having..

When I first start the bike they work fine push the button and they shut off. The problem starts after I turn my first corner. They turn off but will not turn on again after that, I stop turn off the bike and it starts working again but this time they do not cancel by them self or with the pushing of the button I have to push it back to the other direction to cancel. Let the bike sit for about a moment and function works fine tell first corner again. I have had a new rear tire put on this bike 150 miles before this started could have something back around there been messed up??



:?
 

·
Registered
Joined
·
2,795 Posts
imported post

I'd start by cleaning the switch, so as to eliminate a mechanical problem.

Open the plastic housing to the left handle bar (2 screws), then liberally spray the turn signal switch with electrical cleaner, while working the switch.
 

·
Impersonating a mechanic
Joined
·
1,139 Posts
imported post

I'm not familiar with the 1500, but I just fixed a similar problem on my GL1100. Turn signals were working very intermittently. I pulled both cables off the bottom of the flasher, and one of the connectors broke in about three pieces. Just replaced that connector, and it's working fine again.

Then I took it for a ride and noticed that the fuel gauge said I had no gas. So I took the seat off again and cleaned up the connectors that were located atop the gas tank. (They were crusty.) Problem solved.

So I suggest that you clean up the turn signal switch, as Alex mentioned, and thenall the connectors in the circuit, including the automatic shut off. This will also ensure that any connectors that might have been loosened by your tire changer are now tight. Good luck.
 

·
Premium Member
Joined
·
11 Posts
Discussion Starter #5
imported post

Okay I have tried cleaning the switch. Now if I roll the bike forward (before turning on the turn signal) about a foot I cannot turn on the turn signals at all. If I turn them on and roll forward they will stay on tell I move the switch to the other direction the push button does not work. Now turning off the key switch off and, then back on seems to reset the problem.
 

·
Premium Member
Joined
·
11 Posts
Discussion Starter #6
imported post

Okay got the book did the testing they showed me to do points out that the self cancel control unit is malfunctioning. The Honda shop wants 229.95 for this unit does anyone know where to get it cheaper?
 

·
Premium Member
Joined
·
6,132 Posts
imported post

EBay......
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top