Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Premium Member
Joined
·
3 Posts
Discussion Starter #1
imported post

1993 GL1500 Aspencade
Hitachi LR140-708 alternator drains the battery when parked. Too hot to touch when running, but still shows only 12 volts at any RPM. No changes after replacing voltage regulator.

Full disclosure: I am helping diagnose this bike.

Alternator tests good off of the bike.
 

·
Premium Member
Joined
·
4,608 Posts
imported post

Hitatchi alternators are notorious for failing. Alot of us send them to Ken Hemmings in Indiana for a complete rebuild. He'll make it dependable, and with a bit more oomph. Cost is about 200 bucks, and you'll have it back in about 7 days. You could take it to a local shop as well, but Ken is a 1500 alternator guru! He does bike alt.s exclusively, and he has built special tools to do his magic. Seems the windings are "crimped" instead of soldered, and the winding wire from the factory was junk. Mine had blown the regulator diodes, and was so hard on my AGM battery, it ruined it. Good luck with it, it CAN be made into a decent alternator. jimsjinx
 

·
Premium Member
Joined
·
1,304 Posts
imported post

If it is too hot to touch when running Jack and 12 volts at any rpm, you need to get it replaced or overhauled.
 

·
Premium Member
Joined
·
3 Posts
Discussion Starter #5
imported post

Thanks guys. Had a rebuild shop install the new regulator and they said I may have a bad rotor that they could not get to fail during their tests.

I saw online that the rotor is a weak link with this alternator.

Replacement 95 amp version is about $250. Not a bad price but I worry about my wiring. Battery and ignition terminal show good continuity.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top