Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Premium Member
Joined
·
4 Posts
Discussion Starter #1
imported post

I have a 2001 GL 1800 after the bike sits for a while when the key is turned on the FI light dose not come on which it should until the bike starts and the bike will not start. After turning the key on and off a few times the FI light comes on and the bike will start and it runs great.
I need all the help I can get :applause:
 

·
Administrator
1987 GL1200 Interstate
Joined
·
22,756 Posts
imported post

Welcome to the forum, Dwing.

This one will be easy. Hang in there and someone familiar with the 18s will chime in shortly.
 

·
Administrator
Joined
·
26,561 Posts
imported post

I suspect the FI/IGN relay may be failing to contact sometimes.

Also could be the kill switch.
 

·
Premium Member
Joined
·
1,735 Posts
imported post

Another possibility is the connector for the ignition switch. A plug might have worked it's way free and causing only a momentary connection/disconnection. Has the plastic been off recently that you know of? say for an air filter change or something. I believe that some of the wiring for that goes over the top of the air box.
 

·
Premium Member
Joined
·
4 Posts
Discussion Starter #8
imported post

Thanks DAVE0430 for the feed back I change the FI relay problem gone for now thanks again. :claps:

You are a SENIOR GURU as far as I concerned.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top