Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Have anyone had a problem with the signal lights not working?
I Just installed a kit for the 4 way flashers (would not turn off). Now that the 4 way flashers are working properly my turn signals is on but will not work. Please someone who have had this problem get back with me so I can fix the signal lights. "It's time to ride"!!!!!
 

·
Still Learning
Joined
·
13,274 Posts
Welcome to the forum crusin2001
You say you installed a 'kit'? Please clearify what you installed, part numbers and a link if you ordered it. Also you say turn signals are on but not working? Not flashing?

Most of the time the switches are dirty and sticky needing cleaning with spray electrical contact cleaner, spray in beside the switch lots of ecc, (be sure and cover the fairing pieces to protect from overspray and drips, work the switches lots, sometimes a shot of wd40 helps to get it started, but needs the ecc after to complete it.
Or you can pull the switches apart inside a 2 gal Ziploc bag to catch the springs inside and clean out the old grease inside that gets all gummy, there are posts on doing this in the forum, use the search tool. It might be in the reference and FAQs section. I can'tuse the search tool on my phone or I would post the link.
 

·
Still Learning
Joined
·
13,274 Posts
To add to that all the switches on the bike need the ecc cleaning yearly. They get dirty and it gums the switches to sticking.
 

·
Gregarious Greeter
Joined
·
16,809 Posts

Welcome:waving:crusin2001
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top