Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Premium Member
Joined
·
4 Posts
Discussion Starter #1
imported post

76 GL1000, fuel temp guages not working, nuetral light won't turn off, I have checked the guages/sending unitwith OHM meter checks out ok. Any suggestions?
 

·
Premium Member
Joined
·
210 Posts
imported post

Have you checked the 7 volt regulator? They prone to fail. As for the neutral light staying on, the switch is probably gummed up. Try a good oil flush and use some Marval Mystery Oil in the crankcase, After a 100 miles or so it might resolve itself. Otherwise you'll have to pull the switch to clean it

Don (former 76 owner)
 

·
Premium Member
Joined
·
275 Posts
imported post

There are plans around for building your own 7 volt regulator for the gauges. I think Randakk has a link to one.
Besides the neutral switch contacts gumming up - if the neutral light wire is grounded anywhere the light will stay on. I had a bare connector at the switch end and it was grounding to the block. Easy fix once I found it (and it took a while to find it).
There is a diode in the safety system (clutch switch and neutral light) that can fail and cause the neutral light to go on depending on the clutch switch. That failure doesn't happen often.
 

·
Premium Member
Joined
·
4 Posts
Discussion Starter #5
imported post

Thanks guys for the help, I guess while checking the voltage regulator I must have moved something just right, probably a ground, and they started working just fine. I will dig into the neutral light another day.

Thanks again:thumbsup:
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top