Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Premium Member
Joined
·
79 Posts
Discussion Starter · #1 ·
imported post

Well at one time it only worked through the headset. It has never worked through the speakers. I have tested the speakers and work great. I used to change channels, but not anymore. I can see the FM channel on the dash, but won't let me change channels with the panel nor the left handle bar control. It will let me switch from FM to AM tho. It just stays on channel 88.1.

The CB stays on channel 1 and it won't let me change it ether. I lost the headset about 2 years ago and don't know if it works anymore.

Anyone had this problem before?
 

·
Premium Member
Joined
·
79 Posts
Discussion Starter · #2 ·
imported post

I'm going to tear into it tomorrow before the long ride. I know it's hard to tell me what the heck is wrong,, it could be 100 things. I may try to install a marine CD player later on. A buddy put on his bike.
Thanks tho
 

·
Premium Member
Joined
·
5,734 Posts
imported post

yep--- time to check all the fuses and connections , dont for get to clean the switchs.
 

·
Premium Member
Joined
·
1,185 Posts
imported post

On both my 1200 and 1500 I have had trouble with dirty contacts on the handlebar controls.

John
 

·
Premium Member
Joined
·
662 Posts
imported post

troutdog wrote:
Well at one time it only worked through the headset. It has never worked through the speakers. I have tested the speakers and work great. I used to change channels, but not anymore. I can see the FM channel on the dash, but won't let me change channels with the panel nor the left handle bar control. It will let me switch from FM to AM tho. It just stays on channel 88.1.

The CB stays on channel 1 and it won't let me change it ether. I lost the headset about 2 years ago and don't know if it works anymore.

Anyone had this problem before?
:waving:Do you also have the Intercom option? If so is the "SP/Mute switch in the off position? If it isn't you will only receive AM/FM audio through the headset. At the bottom of the CB controls is a "SP" push button to change from headset to speakers and if it is in the wrong position CB audio wont' be heard in the speakers. And has already been suggested the other problems might be caused by blown fuses.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top