Steve Saunders Goldwing Forums banner

1 - 12 of 12 Posts

·
Registered
1984 GL1200 interstate
Joined
·
8 Posts
Discussion Starter #1
I'm a little stumped......turn signals illuminated, but not flashing.
If i disconnect the front left lamp via the 3 pin connector, the left rear will flash when the left signal switch is selected.
Same is true for other side - disconnect right front lamp, and right rear will flash when right signal switch is selected.

Any thoughts?
 

·
Registered
1984 GL1200 interstate
Joined
·
8 Posts
Discussion Starter #2
Well, sometimes perseverance pays. Diddled with the indicator switch and it would suddenly allow normal operation. Horn still doesnt work, so I'm betting a new switch is in order. Let's see if they exist.
 

·
Administrator
Joined
·
26,567 Posts
The flasher is the problem, bet it won't flash again tomorrow. Go to the parts store and get an EL12 flasher and all will be well. Check the horns before replacing the switch.
 

·
Registered
1984 GL1200 interstate
Joined
·
8 Posts
Discussion Starter #4
I will definitely give that a shot, way cheaper than replacing the switch....
 

·
Administrator
1987 GL1200 Interstate
Joined
·
22,761 Posts
Those switches get dirty. Take it apart (CAREFULLY) and clean the gunk out, then re-lube with fresh dielectric grease. Again...carefully, as there are tiny springs and trinkets in there that love playing hide and seek down in the deepest, darkest, depths of the bike.
 

·
Registered
1984 GL1200 interstate
Joined
·
8 Posts
Discussion Starter #6
as Dave predicted, the next day it only worked intermittently. Getting a flasher today. will tackle the switch over the weekend (if necessary)
 

·
Registered
1984 GL1200 interstate
Joined
·
8 Posts
Discussion Starter #7
So, this is what I got at NAPA. It has 2 prongs. The flasher in the bike has a 3 wire connector going to it. What am I missing here? :)
323627
 

·
Administrator
Joined
·
26,567 Posts
You don't need the green wire on that.
 

·
Registered
1984 GL1200 interstate
Joined
·
8 Posts
Discussion Starter #10
And you were right - but I had to test for myself before I cut off that 3 pin connector. :) all is well, signals flash, and correcting the reversed signal and brake lights on left rear was no big deal either.
Next stop on the tour....replacing timing belts and water pump.
 
1 - 12 of 12 Posts
Top