Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Premium Member
Joined
·
48 Posts
Discussion Starter #1
imported post

my turn signals do not work . ny flashers work though. I've put on another handlebar switch, and nothing. I've put on turnsignal cancel control unit, in steering post , and nothing. flasher is good ,swapped back and forth from flasher. presently I've grounded blue black strip wire on cancel control unit , and it works but I have to cancel it each time. I've ohmed wires ,checked ground conections, and i"m perplexed at what to try next.
 

·
Disfunctional Nimatode
Joined
·
3,381 Posts
imported post

Are you using led lights with the factory flashers? You will need electronic flashers for led's. I switched to led's and since then the auto cancel does not work. Sounds like you have a good understanding on whats going on in the over-all sysytem. I will ponder this for a while and see if I can think of anything else. Sounds like you know there are seperate flasher units for the turns and the emergency. I think maybe you turn flasher may be bad..... the emergency is pulling all four lights creating a stronger power flow through the flasher as the turn is only lighting 2 bulbs and maybe not pulling the required amount of current to make it break..... but you would think the lights would light up and just not blink. Hmmmmmmm...........
 

·
Administrator
Joined
·
26,544 Posts
imported post

Indications are the cancel control unit is bad.
 

·
Premium Member
Joined
·
48 Posts
Discussion Starter #4
imported post

gee guy thanks for still considering my turnsignal problem, I apreciate it. I've got her back togeater right now cause I need to ride. [email protected]
 

·
Premium Member
Joined
·
6 Posts
imported post

Hey Dave,



You still online? I'm having a similar issue with my 84' Aspy. Sometimes the signals work for days then they don't want to work. Just this morning I did my pre-trip checks and they were working. 30 mins. later I was setting up for a left turn and they didn't work. I made the turn and they started working again. I sometimes hear and feel a clicking under the switch. What gives?
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top