Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Premium Member
Joined
·
34 Posts
Discussion Starter #1
imported post

can any one help please . i pres switchfor crusie control the light coms on the datch , but criuise control will not engage ,

i have tried any many speeds .

Is there a fuse for this , have looked in workshop manual cant find .

thanks gerry suny brisbane
 

·
Administrator
Joined
·
26,562 Posts
imported post

The usual problem it seems is the switches on the front brake and clutch levers. Aftermarket levers always cause them to not work from what I have read on this forum. If you have OEM levers try cleaning the switches with contact cleaner.
 

·
Postpubescent member
Joined
·
36,382 Posts
imported post

Try pressing outward on your clutch and brake levers just before trying to set the cruise. If that causes the cruise to set check the bushings in the levers to see if they are worn and fit the bolt loosely. This can cause the cruise to fail to set. As already mentioned aftermarket levers often don't function well with the clutch and brake switches. Often that can be fixed by gluing a bit of beer can aluminum on the part of the lever that contacts the switch plunger. Besides the front brake and clutch there are two other switches to check for proper operation, the rear brake switch located by the rear master switch and the throttle closing switch located near the lower throttle cable attach point. Any one of these switches will cause the cruise to malfunction if they don't work properly.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top