Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Premium Member
Joined
·
222 Posts
Discussion Starter #1
imported post

My riding partner's 1989 SE lost it cruise control.
It was acting up last year, so after the control was cleaned out, it worked fine for 10 rides. It has now stopped working, but the light on the dash will come on.
I told him to look for the relay and try to swap with a known working relay.
What else should we be looking at?
 

·
Just another ORF!
Joined
·
8,189 Posts
imported post

Do both the Cruise and the Set lights come on, or just the Cruise?
 

·
Premium Member
Joined
·
266 Posts
imported post

There are two micro switches behind both the brake and clutch levers and the switches can be fussy particularly if you have aftermarket levers. Try pushing the levers firmly forward and seeing if the cruise then works. If so, you may need to file, grind or fit/finish lever for better switch button contact.
 

·
Just another ORF!
Joined
·
8,189 Posts
imported post

Don't forget there's also a micro switch on the rear brake pedal!

I lost my cruise last year after my speedometer cable broke, on the way home from NASSIR I.

I replaced the cable over the winter, but the cruise didn't work when I got the bike back on the road this spring. :(

I checked both levers and I could hear themicroswitchon the clutch, both on the front brake lever, but not on the rear brake pedal. I just finished a major rework on my aux wiring system and decided to adjust the rear micro switch and it is now working. :action:


Dusty
 

·
Premium Member
Joined
·
212 Posts
imported post

I believe there is only one microswitch on the clutch lever.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top