Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Premium Member
Joined
·
56 Posts
Discussion Starter #1
imported post

could i ask you folks with solid axles to check and see if you have axle seal leaks, or am i the only one with both axles leaking? (1500 w/ 2011 kit)

after each ride both seals leave the bottom of the axle wet.

one seal replaced and it helped but still leaks,,, i have drained the oil and made sure it has only one quart as specified by champion.
(and btw,,it was very black and contaminated at 3k miles) __________________
 

·
Premium Member
Joined
·
932 Posts
imported post

That isn't normal. If you still have warranty on the kit take it back to be fixed properly.
 

·
Premium Member
Joined
·
56 Posts
Discussion Starter #4
imported post

thanks guys

another problem i had out the door;
the left caliper was mounted against the rotor and rubbed badly on right turns, the outside brake pads were making only light contact with the rotor,, dealer didnt catch it.(the axle or something is flexing)
i used spacers to center the rotor within the caliper. champion said i need new caliper,, i dont kn if that is the problem,, with will have the dealer change it.

Gloryrider
have you taken any turns at higher speed? that is when my leaks came to life.
 

·
Premium Member
Joined
·
101 Posts
imported post

I have a 98se triked in 2000 I had it up on the lift yesterday just to check everything out. No wet or even damp spots anywhere and I'm fairly agressive on the turns 47xxx on the bike 6000 of them I put on this year.
 

·
Premium Member
Joined
·
54 Posts
imported post

Yes I have taken turns at higher speeds all is OK.
I see that the caliper come real close to the rotor.
So far there is no problem also.
 

Attachments

·
Honda Guru
Joined
·
2,044 Posts
imported post

Oh boy… I'm putting on the 'way back' hat….

seems some years back there was a axle seal leaking and it was a 'single lip' version. Updated to a 'dual lip' seal and it worked fine.

Or there might be something mis-machined. Is there a vent on the final drive that could be clogged??? Could be wrong bearings installed and allowing slight play… that will cause a leak also.

Either way… it's not normal and should be fixed. I used to build Lehman trikes (at Wing Worx in California) so I also saw my share of Champion trikes also.
 

·
Premium Member
Joined
·
56 Posts
Discussion Starter #8
imported post

regarding the axle vent-- there is one behind the brake line and hard to see but i could feel ,, its a soft rubber vent and of course its got 3k miles on the trike.,, it will eventually go back to the dealer when i can get it there.... one old mechanic has told me he has seen some actually quit leaking once it has some miles,, ha ha. what an awesome feeling,, ive invested enough money to buy a new car and having all these problems
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top