Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Premium Member
Joined
·
289 Posts
imported post

Hi I'm just reading of your plight As the ex prez said "I feel your pain" only I really do. I just finished paying for a new stator installed.....OucH anyway I read you had a cruise control installed and in reading in thisgreat site somewhere Isaw that a blownfuse on a speed control had caused his bike from charging....... ( you hope )... And If I'm not mistaken the stator puts out approx 50 volts AC on all three prongs of the dreaded yellow plug ( I could be wrong ) so you should not be checking for DC..........again there's plenty o people here can tell you much more than me...But check that fuse---Rod :cooldj: best of luck inyour future
 

·
Premium Member
Joined
·
289 Posts
imported post

I paid $1550 for the stator, installation , and a voltage regulator...........I was told by two or three people that know (one a Honda mech. )to make sure to get new voltage regulator. I was going to do it myself but a mechannic friend had done it before and I had my hands full with my 1100 and bad wireing.......... I've been told it can cost upto$1800 so shop around...... And change your oil more frequently I'm told the acids in the oil eat at the coating on the stator...And finally check the yellow wires to ground if any go to ground get out your wallet. Rod :gunhead:
 

·
Premium Member
Joined
·
289 Posts
imported post

I read some where in these hallowed pages that someone' bike wouldn't charge due to a blown fuse in a cruse control but I think it was an 1800 if what's left of my mind serves me............ But like I said I don't know how I'm only the messanger of hope.................. Ya right! best o luck again over and out Rod :cooldj: ( I think i hear the voices)
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top