Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 13 of 13 Posts

·
Premium Member
Joined
·
675 Posts
Discussion Starter · #1 ·
Hi gang!

Have a '98 SE and my cruise control has ceased to function. The cruise and set lights come on when the ignition is turned on but when I attempt to use the cruise, the cruise light comes on but the "set" does not and the cruise does not work.

Have searched the forum for a like problem but have not found an exact duplicate.

Any ideas? Switch? It appears fine and the connections all appear intact.

Cheers!

T.
 

·
Premium Member
Joined
·
6,319 Posts
Also the clutch lever.

Make sure all levers are out/released as far as they go. Push out on them when setting the cruise. Clean the set button contacts as it could just be dirty there.
 

·
Premium Member
Joined
·
28,832 Posts
The single biggest failure is the on the handlebar brake lever there are 2 switches so just because you hear a click doesn't mean it's working. The switches are open air (Honda makes them that way) so dirt gets in them they come out with a single screw spray WD40 inside while working the switch when both are working and clicking put them back in the bike. If you have installed new chromed levers most of them don't hit the bottom switch which is the one for the cruise control on mine I super glued a small piece of metal extending the contact point a half an inch and no more problems.
If you have taken your clutch lever off recently did you remember to reinstall the spring if not the lever will not come all the way out and your set will not engage. The clutch lever needs to be all the way out and against the stops if the spring is not there the wind from normal speeds will push the lever back just enough that the cruise will not engage.
If all these and the brake light switch on the pedal is ok then you need to remove the lower plastic on the left side of the bike (that is where your left foot sits) the plastic is the one that the running lights are mounted in. After you get it off to the left of the opening is a black cannister about 10 inches long and the diameter of a coke can. It has a single hose going to it pull that hose off and check the rubber for cracks or breaks I trimmed about a half of an inch off mine then reinstall. The wing doesnt maintain enough vaccuum so they use this cannister to help out. If none of this works contact me and I will tell you more places to go....PP
 

·
Premium Member
Joined
·
296 Posts
Replace the brass bushing on the clutch lever...if this is worn, it will not allow the cruise control switch to be depressed and allow the C/C to work. To test, while driving, gently push and hold the clutch lever FORWARD. if C/C activates..this could be your issue.
 

·
Premium Member
Joined
·
675 Posts
Discussion Starter · #11 ·
Thanks gang.........will get at trying some of your suggestions this coming week. Am retired, so have trouble finding the time! ;)
 

·
Premium Member
Joined
·
675 Posts
Discussion Starter · #12 ·
Thanks to everyone! I found time while cruising down the freeway this morning to fiddle with my clutch lever and EUREKA I got the cruise to work.
When I WAS working we had a saying in the air ambulance trade that "Common problems happen commonly"............in other words, try the obvious first stupid!

I will be replacing the brass bushing and cleaning up the clutch/cruise switch so that I do not have to make a practice of engaging the cruise switch, pressing the set and fiddling with the clutch lever.............would seem a sort of distraction.............

As usual this site and its members are a great help. If there is ever anything I can help YOU guys with..............

T.
 

·
Premium Member
Joined
·
675 Posts
Discussion Starter · #13 ·
Update..............

My cruise is now functioning normally after replacing the brass bushing in the clutch handle. Total cost $8.02 plus 5 minutes work!

Full marks to wingpilot96 and redwing52!

My thanks again to all who chimed in with advice.

:bow: T.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top