Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Premium Member
Joined
·
2 Posts
Discussion Starter #1
imported post

My cruise control thus not set for some reason I have tried everything, thus anybody have this problem. Need help Eagle:(
 

·
Premium Member
Joined
·
1,028 Posts
imported post

You don't mention of the "CRUISE ON" light comes on. If the light comes on then a blown fuse is not the problem. Most cruise problems on the 1500 (probably the same on 1800) are down to stuck switches (either clutch or brake lever, or brake pedal). The usual switches to go bad are the clutch or brake lever (they are more exposed to the weather). To test the handlebar switch, put your ear close to each lever in turn and slowly depress it. You should hear two faint clicks, if you only hear one click on any of the switches then that switch is stuck in the open (cancel) position. Sometimes a spray of WD40 or similar will loosen it up, otherwise you will need a new switch. Test them and let us know what happens.
 

·
Premium Member
Joined
·
720 Posts
imported post

On a 03 I wouldn't spend too much time on this. Do the checks that Jason suggested and if that doesn'fix it get straight back to your dealer, you have a two year warranty.
 

·
Premium Member
Joined
·
2 Posts
Discussion Starter #4
imported post

Jason, thank you for your info. the problem has been solve on my cruise control, when I change my stock levers to chrome I notice that on my left lever was not relising all the way to the back, anyhow thanks again. eagle:D
 

·
Premium Member
Joined
·
1,028 Posts
imported post

Well done eagle. Those darned aftermarket chrome levers often cause more problems that they are worth. You often have to file them down so they contact the switches properly (filing off the expensive chrome in the process). I ended up junking mine because the brake lever kept sticking the brake lights on, I just got another set of Honda black ones and won't touch chrome ones again.
 
G

·
Guest
Joined
·
0 Posts
imported post

eagle wrote:
Jason, thank you for your info. the problem has been solve on my cruise control, when I change my stock levers to chrome I notice that on my left lever was not relising all the way to the back, anyhow thanks again. eagle:D
eagle, It's important when the levers are changed on the 1800, that they are replaced by the same type in chrome, that is to say they should have the adjusters fitted on each one. :cool:
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top