Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Premium Member
Joined
·
1,798 Posts
Discussion Starter · #1 ·
Hi Guys,

I out this kit in today on my2009 1800 and it doesn't look anything like the photos posted on the EC website

http://www.electricalconnection.com/other-lighting/01350.htm

Has anyone else installed this kit and had either success or failure... Mine doesn't look anything like what they show on their website...

Les
 

Attachments

·
Premium Member
Joined
·
6,183 Posts
Looks the same to me, even the out of focus pictures. It's just supposed to light the area between the buttons, looks to me....
 

·
Premium Member
Joined
·
1,798 Posts
Discussion Starter · #3 ·
compared to my picture though, my installation isn't lighting up anything!!!

Les
 

·
Premium Member
Joined
·
6,183 Posts
In the EC webpage, I don't see anything being illuminated except the cracks between the switches. I am pretty sure that's the way is supposed to be. So you can see the division between the switches. It's not going to show much else. The lettering is solid, so not light is going to show through them.
 

·
Premium Member
Joined
·
2,295 Posts
Yep… you got what you paid for. The description even says they are for backlighting the switches.

You must have got confused with the pictures shown with the description in that the buttons and text were actually being lit up. They aren’t.

Tim.

:?
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top