Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Premium Member
Joined
·
118 Posts
Discussion Starter · #1 ·
imported post

Need some guidance from my GW brethren. Getting bike ( 1981 GL 1100S)ready for Floridas' prime riding season ( late fall, winter, early spring). Battery would only click the solenoid. It was 4 years old and wouldn't take a full charge, so I replaced it. New battery clicked solenoid louder, starter seemed to be bound up, finally started to spin and bike started. Exhaust was full of fuel. When it spit it all out, ran fine. Some background; this bike has always been finicky when stone cold. Won't tolerate ANY choke and very little fuel or it will flood. Once it starts and warms up, always runs fine. I am a carburation idiot, but any input would be appreciated. Planning on running some Seafoam thru it. That's the extent of my fuel system capabilities.
 

·
Premium Member
Joined
·
118 Posts
Discussion Starter · #3 ·
imported post

Thanks, newday. I always close the petcock when it's sitting. Been a bad boy re: fuel filter. Been paranoid about it since reading about the Emgo issue, but not paranoid enough to get off my ass and change it! Will do so ASAP plus the Seafoam regimen. We do have some twisties here in rural central Florida; you just have to know where to look. BTW, if that's Snowshoe in West Virginia in your avatar pic, I've been there.
 

·
Premium Member
Joined
·
118 Posts
Discussion Starter · #5 ·
imported post

Thanks again. Stopping at NAPA store on my way home today.
I ain't much for skiing but I told my buddy who has a condo at Snowshoe that I'd like to come back with my bike. Plenty of twisties around there!
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top