Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Premium Member
Joined
·
3 Posts
Discussion Starter · #1 ·
imported post

The #5 fuse which is a 15amp fuse keeps blowing, with that my instrucment panel doesn't work, no reverse, no fog lights, trunk and saddlebags side lights don't work, and the trunk brake light is not working when I hit the breaks, what could be causing the fuse to blow the fuse on the fuse cover saids it for the tail relay.

:?
05 grey GL1800
 

·
Premium Member
Joined
·
3,624 Posts
imported post

Sounds like you have a loose ground or broken ground wire somewhere. Being an 05, I would first look for a loose ground wire somewhere in the harness.
 

·
Premium Member
Joined
·
3,624 Posts
imported post

Not necessarily under the seat, but it's a start. Maybe an 1800 Guru would better answer your question.
 

·
Administrator
Joined
·
26,992 Posts
imported post

#5 fuse does give power to the tail light relay and from there to all the things you say are not working. It is NOT a bad ground. It is very handy to have an amp meter to connect across the fuse terminals instead of blowing fuse after fuse. You need to begin by disconnecting components one at a time until you find where the short is. The fog lights are an add on so start there, remove the left pocket and disconnect the fog light switch. If any other lighting has been added disconnect it. Then remove all the bulbs in the rear lights. Bulbs have been known to short out internally. After doing the above if you don't find the short give another shout.

Also if you have trailer wiring disconnect it.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top