Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
21 - 40 of 44 Posts

·
Administrator
Joined
·
25,336 Posts
Sounds to me like a shotgun fix, throw parts at it until it works.
 

·
Administrator
Joined
·
22,182 Posts
Discussion Starter #22
I crawled under the car this morning and squeezed those hoses. I couldn't feel any pellets in the big one and couldn't find access to the small one.
I'll take the canister off and have a look-see later. First the car gets washed. I parked under a tree at Wal-Mart last night, and...
 

·
Administrator
Joined
·
25,336 Posts
I just doubt the canister has anything to do with your problem. Not familiar with Hyundai's but they are all pretty similar. There should be a flapper valve in the tank that keeps fuel from coming back up the vent hose that may be stuck closed. It may be possible to remove the vent hose that goes up to the filler neck and poke a wire in the tank to break it loose.
 

·
Administrator
Joined
·
25,336 Posts
so, from that, you would infer that they want us to stop pumping gas into our cars with the 1st click off of the pump handle?
That is what the manufacturers suggest.
 

·
Administrator
Joined
·
22,182 Posts
Discussion Starter #28
I jacked the car up, crawled under and found the hose that was filled with charcoal pellets. So I decided it was time to take the canister out.
That little bugger didn't want to come out but I persisted.

Pic 1 shows the whole shebang. Pic 2 must be the diagnostic module, but I can't find a pic of one to confirm that. Pic 3 is the steel hose that the rubber hose that had the pellets in it attached to. To me it looks like a vent and no more.

OK, having trouble loading pics right now.???
I'll mess with it more after lunch.
Pics are back, so...
 

Attachments

·
Administrator
Joined
·
25,336 Posts
You're right, it's not working.
 

·
Administrator
Joined
·
22,182 Posts
Discussion Starter #34
It probably doesn't matter if the pics posted. The canister is puking pebbles and it seems like that means it's a goner.

I can get one for 148 bucks on Amazon. Free shipping. That's a 63 dollar saving from the local dealer's (list) price with the tax. I asked the dealer if they would deal/match and they said no.

I have to wait a week to get it, but that's okay.
 

·
Administrator
Joined
·
58,729 Posts
Pictures hosted already seem to work

yeah,
I mentioned that in another thread somewhere,

if the album already has the image loaded, it will be included just fine a new post. Or, if the image was already uploaded as an attachment, it will post in a new thread.

what is not happening is for us to be able to upload any kind of image, whether as an attachment, or into the Albums :(

But, Jeff, you linked to an image on your own server, which is the same as linking to an image already in an Album here on this server...

I like it when a full screen image goes up like the one you just did, it is properly sized to fit the screen.

as of right now, if we want a 'new' full screen image in a new post, it need to comes from another host.... ie, PhotoBucket or something else.
 

·
Just Winging It
Joined
·
3,325 Posts
I can get a used one for $35. I have to get under the car (in a junkyard) and take it out.
Does that sound like a waste of time and money?
Considering you got a new one for 63 yeah 35 for a used one is going to be a big waste of time seeing as there is a great chance the used one will be bad.
 

·
Administrator
Joined
·
25,336 Posts
A used one or an aftermarket one, either one is chancy.
 

·
Administrator
Joined
·
22,182 Posts
Discussion Starter #40
$63 is the savings off the list price, Jeff, for an OEM unit. A used one would save $160. But there is a chance a used one may be bad as well or go bad soon, it's risky. Besides, it was work enough taking a relatively clean one off my car in my carpeted garage. To do the job out in a junkyard...

I'll bite the bullet. It is OEM Dave. See the link.
 
21 - 40 of 44 Posts
Status
Not open for further replies.
Top