Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 10 of 10 Posts

·
Premium Member
Joined
·
460 Posts
Discussion Starter #1
imported post

hi just replaced my water pump using commercial o-rings [not honda] i have a small
oil leak from the weep hole are the commercial o-rings as good as the honda rings
this will be my 3rd attempt at stopping the leak.
 

·
Piled Higher and Deeper
Joined
·
4,513 Posts
imported post

If they are the correct size, it shouldn't make any difference, particularly for such a short period..

The cheaper versions probably use the common cheap nitrile, but again, this stuff in not bad and should be good for many years
 

·
Premium Member
Joined
·
460 Posts
Discussion Starter #3
imported post

hi and thx for the reply. what would be a reason for the small oil leak maybe a drop
should i just ignore?
 

·
Premium Member
Joined
·
187 Posts
imported post

Sometimes after replacement they drip a bit and it goes away after running.
 

·
Premium Member
Joined
·
32 Posts
imported post

Had the same problem with my GL1100. I know it's different but what I found was the third party orings were thinner than OEM orings. I ended up replacing all orings with Honda orings. Leak disapeared.
 

·
Premium Member
Joined
·
494 Posts
imported post

Had you changed the oil pump seal(wherewater pump faces the oil pump)as well?
 

·
Premium Member
Joined
·
494 Posts
imported post

If I were you I would check the coolant and the oil for a cross contamination (coolant in oil or oil in coolant). If no contamination and if the leaking is not big then just ride it.
 

·
Premium Member
Joined
·
4,328 Posts
imported post

There are three places the oil can come from the o ring, one or all of the crush washers on the bolts that hold the pump on to the case and last the oil seal that the pump shaft goes through..SO did you replace the oil seal and the crush washers..it may not be the o ring>>>
 

·
Premium Member
Joined
·
272 Posts
imported post

did you crush an o ring? or maybe you forgot to tighten a bolt?
did you change the seal in back of the waterpump ?
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top