Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Premium Member
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello All
I have a 1986 GL1200 Aspencade that I completed the Poor Boy conversion last fall, Had no problems until this week I was riding along when I lost all electrical power. After checking every thing out I discovered the Main fuse on the starter relay was blown. replaced it and attempted to start bike, when I hit the starter lost all power again I herd a slight click like a breaker or fuse blowing checked all fuses in the fuse block as well as the one on the starter relay and all are ok. got frustrated and walked away for the day. Came back next day removed starter relay checked it out re installed it and turned the key on (POWER) got excited tried to start bike again hit the starter and click lost all power again, fuses rechecked all ok very frustrated now.
Anyone have any ideas on my problem:wtf:
 

·
Premium Member
Joined
·
2,163 Posts
You need to put the stock stator back in it............
Sounds like loose or dirty connections on the battery posts. Take them off, then clean and reinstall.
 

·
Premium Member
Joined
·
249 Posts
Make sure you clean and check both ends of the ground cable not just at the battery. Bad grounds are often the source of problems on wings.
 

·
Alaskan Explorer on a Valk
Joined
·
585 Posts
I too had the fuse blowing after the conversion. I replaced the ignition switch. replaced the starter ( I really think this was the culpert) , replaced the selenoid, cleaned the start/off button, looked at all the grounds. I did find 2 cracked coils- replaced with the exact same coil.
I then added a second fuse box and ran all the new stuff through the new fuse box --leaving the original wiring for the bike to the bike.
After that I did not lose another fuse.

Very frustrating.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top