Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Premium Member
Joined
·
10 Posts
Discussion Starter #1
imported post

i have an 84 goldwing
the oil light is flicker n when i hit operating temp at 500 rpm not below operating temp
it stops at an 700 rpm
i change the oil with 20/50 and a new filter thanking the oil was just old and thin
1 question is what might cause this
2 will a oil pump from a 58 gold wing work on this bike
Misty
 

·
Guru
Joined
·
3,074 Posts
imported post

Welcome to the forum!!! Your Idle speed should be around 1000 to 1050 rpm so you might be running the engine too slow for the oil pump to build pressure.

a good oil for your wing would be Dello 400 which alot of members get at Wal-Mart fairly cheap. I was useing 15 w 40 diesel oil because of the high detergent & the amount of punnishment that oil can take!

Cant remember where, but there is a sump screen on those wings that sometimes gets clogged or restricted causing your oil light problem as well.

You will receive other replies to your post shortly, Stick around, This site is awesome!!!
 

·
Premium Member
Joined
·
588 Posts
imported post

I may be wrong but I don't think the 1200 has the screen like the 1100 does so I think it may be the low RPM's thatis making the oil light flicker. I like Shell Rotella but the Delo is a very good oil also. Randy
 

·
Premium Member
Joined
·
170 Posts
imported post

The oil screen is inside the engine, you don't want to go there! You have to remove & split the engine for that one.

Mine was clean with over 262,000 Kms. on it. Check idle speed and be sure oil filter assembly was installed correctly.
 

Attachments

1 - 4 of 4 Posts
Status
Not open for further replies.
Top