Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter · #1 ·
When I activate my turn signals they light up but won't blink, The flasher is just buzzing, Now remember I've taken of all the goldwing acsesorys fering, bags, everything. I installed after market LED front turn signals and a combination LED tail, brake, turn, license plate light, Is my flasher bad, or do I need to get a universal LED flasher? Another thing how much compression should my 84 1200 have? Like I said before the left side has spark but it's dead, the pipes on the left are cold, If the seafoam I loaded the cabs up through the fuel pump does not work, then i need to check the compression, if it's good then i guess the carbs need looked at, if compression is bad, does that mean head gasket? I changed the oil and it was clean, no coolant in oil and no oil in coolant.
 

·
Administrator
Joined
·
27,888 Posts
The stock flasher relays will not flash LEDs, you have to replace it with an electronic one.
Anything above about 150 psi on the compression is good, less than that down to about 120 it will probably run but be a little weak.
 

·
Premium Member
Joined
·
16 Posts
I'm having the same issue on my gl1200, 84 interstate. However I haven't modified any of it. Any thoughts...
I get a buzz but no blink, not all the time..most the time though...
 

·
Premium Member
Joined
·
16 Posts
Also, trunk lights won't work anymore...but that is definitely a separate issue, I think..
 

·
Administrator
Joined
·
27,888 Posts
I'm having the same issue on my gl1200, 84 interstate. However I haven't modified any of it. Any thoughts...
I get a buzz but no blink, not all the time..most the time though...
Do the lights come on when you switch them on or not?

Also, trunk lights won't work anymore...but that is definitely a separate issue, I think..
Check connections under the seat.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top