Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I just got an 85 ltd and the fm side of the radio only works for a couple of seconds when you first turn on the key, am side and tape deck work fine, but fm side only static. Let it sit for a while, turn key back on fm works for a couple of seconds then static, switch to am works fine, switch back to fm static. I've tried bending the prongs up and cleaning all contacts with alchohol and qtips, no change. Is the fm side just worn out, getting hot losing connection inside the radio? I give. You tell me.:?
 

·
Premium Member
Joined
·
360 Posts
Sounds like its drifting off frequency when it warms up.This radio is 28 years old and it may have a resistor or capacitor loosing its value when it warms up.Try programing a station into one of the memory channels soon as you turn it on when its cold, it may not work but its worth a try.To program a channel find a station with the up/dwn scan switch on the left hand grip, push the ME button then one of the memory channels.These radios have quite a few features,road noise compensation control buttons below the the LED computer readout screen on the Faux tank and mute button on the left handgrip. Your tape deck is working so thats bonus you can use a cassett adapter tape and plug it into an MP3 player or a sirius satellite radio receiver or any other audio source with a mini stereo output jack. I've tried all of the above over the years.
:waving:
 

·
Just Winging It
Joined
·
3,327 Posts
I went after market with a cd player. one day I'd like to add rear speakers and maybe a sub woofer inside the fairing.
 

·
Premium Member
Joined
·
2,790 Posts
just send it back to sierra electronics for repair,have several here that been repaired or checked by them
 

·
Premium Member
1985 GL1200 Limited Edition
Joined
·
3,527 Posts
When you have the radio set to FM does the radio even try to tune to a station when you use the tuning switch on the left handlebar?? If it doesn't, the switch might be gummed up from the old dielectric used inside to prevent the contact's from arcing. Try this: Park the bike outside with the sun shining on it for an hour or so and try it then. The heat from the sun should heat that switch enough so it might work. If it does you'll need to CAREFULLY break the switch apart, clean the insides and repack it with new dielectric grease and reassemble..
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #6 ·
Thanks for the replies guys, that may be the problem is that it is 28 years old and the fm side has been used so much that the signal reciever for fm band gets hot and loses signal, because everything else works perfectly,the switch on the left handlebar works, I can tune to any station but get nothing but static, the presets are set to local stations,nothing after it warms up for few seconds.It has to be something on the fm anteana reciever in the radio,because the am side works fine,can tune to any station and listen all day, to bad there isnt anything on am to listen to! Guess I'll send it to sierra,was hoping for a quick fix.:sadguy:
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top