Steve Saunders Goldwing Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hi Guys
All my warning lights works fine, but when I turn the ignition on all I get is oil pressure and neutral.
I was under the impression I should get all the warning lights on for a couple of seconds.
Fuel gauge works (i think! low fuel). Temp works.
The background lighting in the dash unit works too.
I have no audio unit fitted at all as its toast, but that shouldn't do it should it?
I have no time in the LCD rectangle (actually I have nothing in there). I guess that is linked to the stereo???
The wiring diagram I have doesn't tell me much. All the fuses seem OK, although I haven't been through them all with a meter. As I say all the warning lights work.
Any help would be much appri... apresh...apprrec... would make me happy:laugh:
Thanks
 

·
Administrator
Joined
·
25,371 Posts
I think that LCD unit controls the bulb check. It should work without the radio.
 

·
Registered
Joined
·
378 Posts
There is a ground wire under all of that mess, you will see it as you take out the radio controls. That may be the ground for that whole system. The first thing I look for is power and if I see power then I look for a bad ground.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
Hi Guys
Just to update this problem......
I checked fuse 1 and 10, both were good.
With the key in acc I had 12v at the fuses and the acc connector at the top of the fuse box, but not at the Light green/ Black wire at the back of the lcd.
I checked and checked. 12v with a fly lead direct to the lcd brings the clock up.
In the end I pulled the connector apart that is above the left hand fan. the one that comes from the key.
The connectors were really yuk inside. All white powdery crud. I cleaned them up and the clock comes on now and I get a light test too.
I suppose the connector was good enough to give a reading at the fuse box, but not good enough to actually power anything??

So thank you all for your help and support. Dave0430 was completely correct, the lcd/clock works independently from the audio system.

Now on to the next problem..... Wheres that big hammer?
 
1 - 6 of 6 Posts
Top