Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Premium Member
Joined
·
22 Posts
Discussion Starter · #1 ·
Hi folks, I have a 96 1500 SE. Heres one to figure out..I left work after my evening shift, and made a right turn out of the lot and when the turn signal cancelled itself, my headlights went out. I had to turn on the highbeams, which were not very bright. Then I discovered that whenever I put my right hand turn signals on, the low beams would come on..?! Turn signal back off, lowbeams back off. Can anyone point me where to look? Im going to start with spraying the turn and light switches and ignition switch with electronic cleaner. Thanks for any advice.
 

·
Premium Member
Joined
·
22 Posts
Discussion Starter · #2 ·
I went out and sprayed wd40 into the ignition switch. ( couldn't find the electronic cleaner). As of now the low beams are working..? I didn't spray the headlight or turn signal switches at this point.
 

·
Premium Member
Joined
·
6,828 Posts
I think you are on the right path. I might add that the start switch might be another possibility. When the start is engaged it disengages the low beams. I have had similar and then I just click the start switch a bunch of times with the ignition off and it is good for a long, long time.
 

·
Premium Member
Joined
·
22 Posts
Discussion Starter · #4 ·
Thanks redwing for the reply. I went out today to try it, no low beams except when the right signal is on. Sprayed and cycled all switches. I want to add that nothing was touched on the bike prior, the lights were fine. Any ideas out there? Thanks
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top