Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 9 of 9 Posts

·
Premium Member
Joined
·
37 Posts
Discussion Starter · #1 ·
The speedometer, odometer & cruise control all stopped working. I'm wondering if this could be the speedometer cable in need of replacement. I find it interesting that the cruise control is not working & I believe it's because of speedometer. Can anyone help me please with advice or tips??
 

·
Premium Member
Joined
·
296 Posts
Uh...yep...that could be your culprit. At the front wheel, disconnect the speedo cable and try to remove the actual "drive cable" if it stiff, it could be dry or rusted, if it comes out in pieces...well, it's broke. if the cable is good...then it's the drive gear in the front wheel speed housing that needs replacement.
 

·
Premium Member
Joined
·
37 Posts
Discussion Starter · #5 ·
Dennis, yes, you're right about the signals that doesn't work with self cancelling too. I guess I will set up an appt at garage to fix it. Thanks all!!!
 

·
Registered
Joined
·
2,795 Posts
...I guess I will set up an appt at garage to fix it. Thanks all!!!
Its pretty easy to replace the speedometer cable/housing... only takes about 10 minutes, and $20
 

·
Premium Member
Joined
·
37 Posts
Discussion Starter · #7 ·
Hi all, just had it diagnosed & it's not the speedo cable. It's the sensor housing at the bottom of the cable so that's being ordered now. Should arrive here some time next week...
 

·
Registered
Joined
·
162 Posts
I'm having the same issue - how did you diagnose it?
 

·
Wild Rhino - Canadian
Joined
·
591 Posts
I'm having the same issue - how did you diagnose it?
Get the front wheel off the ground and spin the wheel, if the speedo drive turns it should be good, then you would be looking at the cancel control
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top