Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 · (Edited)
I am having some issues with my Fog Lights not coming on. The button is to the right of the Hazard button, and I am assuming that the button being in the down position means they should be on. Fuses were all checked.

If someone can share there knowledge about this it would be appreciated.
 

·
Old School Guru
Joined
·
7,889 Posts
Probably the relay under the left pocket is bad, or the switch itself have been known to go bad. Both items are easily replaceable, and you can get them cheaper from Cyclemax than from the dealer.:) With a voltmeter, it shouldn't be hard to check either one.:)
Gene:waving:
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Probably the relay under the left pocket is bad, or the switch itself have been known to go bad. Both items are easily replaceable, and you can get them cheaper from Cyclemax than from the dealer.:) With a voltmeter, it shouldn't be hard to check either one.:)
Gene:waving:
Thank you Gene, I will try to find the relay under the pocket. I was going to check the bulbs with my meter but now I will look for the relay. The switch will be a lot harder to get to.
I just finished replacing the dreaded "Air Filter" which took 3 hours, but all other controls are working fine on the left control panel.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
It was dirt in the switch. While I had the control out of the bike I also repaired my Hazard Light switch as it was sticking badly. First I used compressed air, then I used Electrical Contact cleaner, and finally I used some more compressed air. Switches work like new, both of them.

Thanks for all your input!

Kenny G
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top