Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
indicator of the left turn signal is not working, I know the bulb is ok.

and the neutral light is a little brighter than in speed, light is always on but brighter in neutral........

do you think these problems have something in common ?

what i must check ?

Thanks!
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·
i forgot to tell about another trouble and the last....

shocks are loosing air in a short laps of time...
I sprayred water with soap on tube and I saw no bubbles....

are the shocks repairables ?

thanks
 

·
Registered
Joined
·
211 Posts
shocks are repairable if you can get parts. check the small stuff first, the valve, (where you apply air) the orings (on the crossover hose). if the leak isnt there, you probably have bad seals. they can be changed without taking them off the bike but sometimes it's just simpler to do so.
 

·
Vintage Rider
Joined
·
2,410 Posts
The complete air suspension system was shot on my '85 1200LTD. Everything was rotted and rusted, and all the switches were broken. I installed a set of Progressive 416 shocks, put 50 psi in them with a small Walmart compressor, and they have worked just fine.
 

·
Premium Member
1985 GL1200 A
Joined
·
953 Posts
Whenever you have any switch messing up and know the bulb/component is OK, ALWAYS clean the switch thoroughly with contact cleaner.

Remember: "If the women don't find you handsome, they should at least find you handy." Red Green :ROFL:
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top