Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
Premium Member
Joined
·
100 Posts
Discussion Starter #1
imported post

I'm so happy to have found this site. I just bought a 1980 GL1100i. Test rode it, bought it (Aug 1st) rode it home and it died... Oh well.



Lights work but doesn't start. No clicking no nothing!!!



I'm looking forward to participating and learning as much as possible here in the future.



I'm Ken, from South Bend, Indiana.
 

·
Premium Member
Joined
·
6,870 Posts
imported post

Welcome from the
Steve Saunder's GOLDWING FORUM



A Big Welcome FromTEXAS
 

·
Pops
Joined
·
4,519 Posts
imported post

Hello and welcome from Arizona.
 

·
Premium Member
Joined
·
8,524 Posts
imported post

Welcome to the forum, from sunny Southern Califonria :action:
 

·
Gregarious Greeter
Joined
·
16,809 Posts
imported post

Welcome from the state of Pennsylvania!





 

·
Premium Member
Joined
·
9,790 Posts
imported post

Welcome to this Great Site!

Pull up a chair and join on in!

Ride Safe, Ray


:waving:
 

·
Premium Member
Joined
·
4,472 Posts
imported post

Welcome Aboard!:waving:
 

·
Premium Member
Joined
·
100 Posts
Discussion Starter #8
imported post

Thank you all...

Will get back after I've had a chance to charge the battery and actually ride the bike over fourteen miles!!!

Thank you,
Ken
 

·
Premium Member
Joined
·
20,611 Posts
imported post

Welcome to the Forum from Kansas!!! :waving:

I hope you find the Forum as informative and as much fun as we do!!:cooldevil:

Again, Welcome Aboard!! :action:


 

·
Premium Member
Joined
·
7,133 Posts
imported post

Hey! :waving: from Hamburg, NY
[align=center]THIS IS A GREAT PLACE TO BE![/align]

If you have Goldwing Technical Smarts - GIVE IT! :2finger:

If you need help - ASK FOR IT! :blushing:
If you know of an event coming up or a cool ride you went on - SHARE IT! :banana:

If you have a joke or funny story - TELL IT! :cheeky1:[/align]
If you have prayers to give or need some - FOR HEAVEN'S SAKE, SAY IT! :angel:

If you have anything bad to say to or about anyone on this forum - STUFF IT! :whip:

[align=center] WELCOME TO THE FAMILY!!!
:cooler:[/align]
 

·
Premium Member
Joined
·
14,148 Posts
imported post

:waving: :waving: :waving: :waving: :waving: :waving: :waving: :waving:

Hello from Virginia,

Welcome Aboard!!!!!


Glad to have you with us!



:waving: :waving: :waving: :waving: :waving: :waving: :waving: :waving:
 

·
Premium Member
Joined
·
193 Posts
imported post

Hello from Washington state.:waving:

Enjoy the forums.:)

Tib:cool:


 

·
Premium Member
Joined
·
100 Posts
Discussion Starter #14
imported post

It's the morning of the sixth day of ownership!!! A little wax, elbow grease and 180 miles later...



Well, it turns out the battery was bad (wouldn't hold a charge.) I put in a new one and everything's fine!!!



There's much work to be done.

- new tires are on order (waiting patiently)

- source new tach cable

- fix speedo (turns out a 100/90-19 is on now, not the proper 110/90-19, hope that fixes that!)

- fix cigarette lighter!!!

- get radio working

- give the brakes a once-over (when the wheels are off for tires)

- oil change

- final drive oil change/spline lube

- get a "real" pic of me and my bike and post it here!!!



- find a 'lockable' right-side dash cover (ANYONE.... HELLLLLLLP!!!!)
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top