Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Premium Member
Joined
·
30 Posts
Discussion Starter #1
imported post

Hi folks--

First off, wish everyone an upcoming Happy Thanksgiving.

Have been helped here before with positive results, and trying it again. Most recent was alternator problems. Got that taken care of, and ended up buying one of Rudy's SmartTraveler systems. That thing is a huge "mind-easer"!!!!

I have an open face helmet with a J&M speaker system/boom mike, etc. Don't know how old the system is, but just a couple of days ago, the right side speaker quit. We all know the wiring is about as thick as piano wire, and naturally, being on the right side, it's the long wire.

Hooked my helmet up to the Bride's hook-up, and still the same. Put the Bride's helmet to my hook-up (the lower), and all is fine with hers on that same connection, so I eliminated the lower connection being the issue.

Unplugged & swapped the speakers, and it's still the right side not working. Pulled the wiring out of the helmet & "played" with it while powered up....thinking I might find a broken wire, etc, but with no luck.

There is a tag on that specfic wire from J&M with Part #HS-ECD584-OF, Serial #12141. I looked that up on J&M website & can't even find anything with that Part number.

Help!!!! Anything else I need to do or check for? If it's scrap (which I think it is), am I probably going to have to buy an entire new setup for my helmet? Sure hope not because J&M is very proud of them. If that's the case, anyone got a used working setup they want to get rid of?

Thanks again, & ya'll Stay Safe & Cover Your 6-

dotman
 

·
Premium Member
Joined
·
628 Posts
imported post

Have you checked where the lead goes into the headsets? I think those are the ones with the fine pins that break easily.
 

·
Premium Member
Joined
·
354 Posts
imported post

I broke the plastic piece that connects to my helmet. Even though I found the part number, I couldn't find it on their website to purchase. I emailed them and told the story. They just asked for my address and in 48 hours I had the piece at no charge. That is called service and great customer service. Email them.

Carl
 

·
Premium Member
Joined
·
3,318 Posts
imported post

tykub wrote:
I broke the plastic piece that connects to my helmet. Even though I found the part number, I couldn't find it on their website to purchase. I emailed them and told the story. They just asked for my address and in 48 hours I had the piece at no charge. That is called service and great customer service. Email them.
Carl
I had the same thing happen, the plastic piece broke that holds it to the helmet. I tried repairing it but to no avail. Finally I called them and they got my address and sent me the parts I needed at no charge. Good customer service.
 

·
Premium Member
Joined
·
30 Posts
Discussion Starter #10
imported post

I know this is delayed quite a bit,but have been gone, without a computer, illnesses in family, and other things......but I really need to commend J&M Corporation....especially Mr. John Lazzeroni.....plus those of you on this forum for recommending me contact J&M.

Sent an email to J&M explaining my problem, and Mr. Lazzeroni replied very quickly. Sent the unit to them for repair, and every bit of it wasdone under warranty. Got it back nearly immediately after them receiving it.

These are some "old school, squared away" people at J&M, that sincerely, in my opinion, believe & practiceCustomer Service.

They have my business from hereon out.

Ya'll Stay Safe-

dotman
 

·
Still Learning
Joined
·
13,270 Posts
imported post

Good that you reported back on the outcome for you dotman.
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top