Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 20 of 25 Posts

·
Premium Member
Joined
·
8 Posts
Discussion Starter #1
imported post

Looking for advice. I have a 98 SE with a radio problem. I can barely hear the radio when it is at 1/2 volume and there is not much of a increase in volume from 1/2 to full. There is more distortion the more you increase the volume. The sound isbetterwhen using the headset then the speakers. I swapped the radio with another used radio and got the same results. Somene had suggested that it might be the fader control. Does anyone have any suggestion?



Thanks
 

·
Premium Member
Joined
·
2,838 Posts
imported post

You need to add an in line noise filter. You may already have one on one side that may have blown, or just add another. I would get another and replace it. Easily found at Auto Zone or any decent Auto Parts or Radio Shack. (Or you may have to replace your speakers). Have you had it in a high pressure car wash or got it directly wet in a while? That would hurt them. Most are waterproof on the new Wings. Sometimes, the rubber seal can break due to heat and cold expansion, and the speakers will and can get wet. Try hooking up another speaker OUTSIDE of the others, have it braced on something, and crank up the volume. See if it helps. If not, replace the filter.

Good Luck,
Nightrider1
 

·
Registered
Joined
·
10,509 Posts
imported post

Sounds to me the power amp has gone out.
 

·
Premium Member
Joined
·
8 Posts
Discussion Starter #5
imported post

Power amp makes sense, I had previously sent my original radio to sierra electronics and they could not find anything. I figure I can't be the only one with problem.
 

·
Monkey with a Football
Joined
·
19,237 Posts
imported post

My guess is the speakers are toast if the fader is not cooked.
It would be odd to have two channels on an amp both fail with the same symptom unless it as a failure of the power supply feeding both amps.
Especially since you have already had the radio checked.
 

·
Premium Member
Joined
·
8 Posts
Discussion Starter #7
imported post

Is there a easy way to check the fader control?? Speakers have been changed.
 

·
Monkey with a Football
Joined
·
19,237 Posts
imported post

Turn the knob and see if the volume jumps around and sounds scratchy or not. Also gage the smoothness of the control as you turn it.
 

·
Monkey with a Football
Joined
·
19,237 Posts
imported post

You know you could also have shorting in the mute switch or wiring from it.
Does the mute LCD message appear and disappear as you push it in and out?
 

·
Premium Member
Joined
·
1,221 Posts
imported post

Check the 5amp # 13 fuse located at the bottom left of the relay box.:waving::waving::waving:
 

·
Just another ORF!
Joined
·
8,189 Posts
imported post

Just curious .... is your speedo cable broken? :? :baffled:
 

·
Premium Member
Joined
·
109 Posts
imported post

What Shrek says. That single fuse inside the relay box
 

·
Premium Member
Joined
·
8 Posts
Discussion Starter #14
imported post

Fuse is good and the speedo cable is also good. The mute button works fine and the fader control works, it does shift the sound front to rear and not scratchy and volume does not jump around. Does anyone no if there is a single power amp or seperate amps for left and right channels.
 

·
Registered
Joined
·
10,509 Posts
imported post

Single power amp. I'll post a pic of it in a minute.
 

·
Registered
Joined
·
10,509 Posts
imported post
 

·
Premium Member
Joined
·
8 Posts
Discussion Starter #17
imported post

Thanks for all your help, I will look into this weekend. Do you know of a way to test this unit, short of replacing it?
 

·
Premium Member
Joined
·
8 Posts
Discussion Starter #18
imported post

Thanks for all your help, I will look into this weekend. Do you know of a way to test this unit, short of replacing it?
 

·
Premium Member
Joined
·
8 Posts
Discussion Starter #19
imported post

Thanks for all your help, I will look into this weekend. Do you know of a way to test this unit, short of replacing it?
 

·
Registered
Joined
·
10,509 Posts
1 - 20 of 25 Posts
Status
Not open for further replies.
Top