Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Premium Member
Joined
·
1,245 Posts
Discussion Starter · #1 ·
its a sad moment

I got my radio of and did the aux input mod just to make sure all was ok before re install I pluged the radio on the bike all was great UNTILLLLL :lash: I have accidently dropped the two wires that are mounted on the aux switch i guess it toutched a ground on the engine and that was it .......

both fuses are good radio is working but low output and distorded sound grrrrrrrr (actualy ) volume is a little better with switch in on position but stays on radio i dont get aux anymore

Now I took the relay out back to oem just by the 4 wires and the cassette play fine but radio is distorded grrrrrrrrrrrrrrrrrrrrrr

I guess I blew up somethin in the radio circuit
 

·
Premium Member
Joined
·
1,245 Posts
Discussion Starter · #4 ·
Ya Stu the very first thing I did and hope,,, was a fuse I did check both and good sniffff

Molon Thanks I have sent a radio to Sierra in the past and they are good

I am mad at my self i was finished and all was great just a stupid second of negligence and there i am loosin my radio for a few weeks and 150$... cant win them all


thanks guys
 

·
Premium Member
Joined
·
1,245 Posts
Discussion Starter · #8 ·
I done it my self.. easy if you can do small work with souldering iron.

i am mad because I have done it all and it was greatly working until I F**ked up grrrrrrrrr

Found a place that does radio repair on goldwing radio and CB in canada i will give him a call monday ....
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top