Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 10 of 10 Posts

·
Premium Member
Joined
·
17 Posts
Discussion Starter #1
imported post

"Hello anybody" I have recently replaced the water pump and all went together
fine with neutral light still working correct however I had an oil leak, that was unacceptable, so I more neatly tore he down without taking off the timing belt covers,
put 2" bear of RTV Black Silicone at lowest point and put her back together, eveything
lightwas fine "No Leaks" but I had no Neutral Light, so I have been guessing where it is...and pulling in the clutch to start, Recently was out riding at night and found neutral light between 2nd and 4th, any ideas how I an fix this without tearing her down again????

"PLease Advise"

Ron
 

·
Premium Member
Joined
·
342 Posts
imported post

Well, hate to be the bearer of bad news, but my guess is that the switch wasn't lined up quite right when you put the front cover back on (just did my 83 pump a few weeks ago)...if this is the case, only fix is "off with the front cover...again"

If it at all makes you feel a little better, I missed it the first time & had to pull the freakin' thing off again to line it up.

Best of Luck...Dave
 

·
Premium Member
Joined
·
17 Posts
Discussion Starter #3
imported post

Thanks, Dave I think I will enjoy my bike for a few more weeks
now that I'm planted in Northern CA, The lake Tahoe bike run looks good today and maybe again with a group next weekend..

Thanks for the bad news, I just didn't want to go there if
I didn't have to, There's no tricks I guess outside of just getting it right.

Thanks again,
Ron
 

·
Premium Member
Joined
·
5,713 Posts
imported post

Can't help you on the neutral light, but I like the heck out of your fairing!!..if thats your bike in your avatar:shock:..

Did you do the work to put the extra lights in, or was it like that when you bought it?
 

·
Premium Member
Joined
·
4,379 Posts
imported post

thats a common problem, you must strip the pump case again and reinstall the switch.

yeah. what have you done to the fairing? looks nice, how about some pics?
 

·
Premium Member
Joined
·
17 Posts
Discussion Starter #8
imported post

Did all the work myself, as I used to be an Professional Automotive Industrial Sculptor,
and did this back in 1999 in my spare time, I have master molds in epoxy and I used to be a professional show car painter to boot" I was considering advertising this as a kit at one time, then I got too busy, Thanks for the compliment, it's fun!

Ron
 

Attachments

·
Premium Member
Joined
·
1,572 Posts
imported post

Cool fairing Ron. If you produced it, you could probably find a few buyers on here.
 

·
Premium Member
Joined
·
92 Posts
imported post

Hi,
Excellent job on the faring!! Very good looking paint also. Must be those long Michigan winters that give you time to do that kind of work.
Greg
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top