Steve Saunders Goldwing Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello everybody,
I'm a old retired guy that just bought my first Gold Wing, a 1995 se 20th edition. the previous owner did a very good job of completing all the normal stuff....tires, timing belts, carbs and almost everything that a 25 year old bike could need. The young man that owned it was very good at doing the work himself. Kinda rare these days...anyway, I have been on a few 200 mile rides in the northwest, few mountain passes, interstate and two lane roads. love it,really love it. runs like new!!! massive horse power and 42 mpg at 85 mph, 37 at 55, go figure.

But, the cb, fm, and cruse control switches only work when they want to...any hints on how to fix these? is it just dirty switches? works sometimes....cruse works after it gets warmed up most of the time.

also the temp sending unit seems to be faulty, is there a way to replace this from the top rather than removing the radiator?
I have the honda service manual, seems like it might be easier to replace from the top.

I am going to start working on it this winter. I am also going to install a switch in the fuel pump wiring so i can drain the float bowls without tearing the front of the fairing off. seems like a good idea anyway.

any hints or help would be great.
Thanks
 

·
Administrator
1987 GL1200 Interstate
Joined
·
22,999 Posts
Welcome to the forum. Where at in the NW?

Stuff not working can be dirty switches. Next time the cruise won't work, check the rear brake light switch. It can stick the brake lights on. Gotta say, those mileage numbers are suspicious.
 

·
Premium Member
Joined
·
70,346 Posts
Hallo MeasureUpOne

Welcome on this nice forum. Wish you al the best.
And good luck with your Wing.
 
1 - 4 of 4 Posts
Top