Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Premium Member
Joined
·
13 Posts
Discussion Starter #1
imported post

Had to remove CD player as one cd was jamed tight. I put the CD player back together.

After connecting the cd player - both the radio and the CD player are dead.

The screen shows the station but NO Sound.



Please can anyone help......... Gary
 

·
Premium Member
Joined
·
1,572 Posts
imported post

Welcome to the forum foot. If you did not disconnect the battery when you took the cd player out, you might try disconnecting it for a minute and then reconnecting it. That system seems to want to be reset after you add or remove something. Otherwise, I'd suggest one of the connectors you played with is not tight. Also, check your mute switch.
 

·
Premium Member
Joined
·
13 Posts
Discussion Starter #3
imported post

It's a pain in the bum. It's never given me any problem in the last 6 years. I checked the mut swich and the fuses.
I have had the battery disconnected for over one hour.
 

·
Other side of the pond
Joined
·
3,409 Posts
imported post

Check the fuses again Gary, and check that you didn't plug the CD player back in wrong.
 

·
Premium Member
Joined
·
13 Posts
Discussion Starter #6
imported post

I have the radio up and running but the CD player is another matter. Had a qualified Tech look at it and he tell me that he has NO idea why it wont work.
 

·
Premium Member
Joined
·
13 Posts
Discussion Starter #7
imported post

Thank you to all the Wing riders who have tried to help.

The CD player had a stuck disk then lost power ?

All this happened after hitting the hole from hell.
 

·
Premium Member
Joined
·
1,572 Posts
imported post

That CD unit is just an accident waiting to happen. There are alot of us that have removed them and replaced them with the plug in style mp3 players that are controlled with the handlebar controls. Much easier and no moving parts to get screwed up when hitting a pothole.

I have one like this:

http://www.cyclemax.com/inc/sdetail/120/63575
 

·
Premium Member
Joined
·
1,074 Posts
imported post

Make sure your display shows speaker symbol and not the headset symbol on the upper left side of the display screen.
 

·
Gregarious Greeter
Joined
·
16,809 Posts
imported post

[align=center]

[/align]
[align=center]Welcome foot131[/align]
 

·
Premium Member
Joined
·
13 Posts
Discussion Starter #11
imported post

From down under I thank one and all for your suggestions and will be back on line in a few weeks.

again thank you world wide.

foot131:waving:
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top