Steve Saunders Goldwing Forums banner
Status
Not open for further replies.
1 - 4 of 4 Posts

· Premium Member
Joined
·
4 Posts
Discussion Starter · #1 ·
imported post

I have a 1997 GL1500 SE. The radio is ok and was checkout by Honda. I think theproblem is in theMute switch/control? Does anyone have adetail diagramofthe Mute/control switch or any other suggestion? The radio plays but very faint. Thanks
 

· Premium Member
Joined
·
4 Posts
Discussion Starter · #4 ·
imported post

I have sprayed (heavy) both WD40 and Electrical switch cleaner into the switch. If I could take the switch cover apart, I might be able to see the switch problem? Looks like thecover is sealed? One other thing I have considered is locating the mute control wire and cut it. I'll use the volume control on the radio. Dennis
 

· Premium Member
Joined
·
4 Posts
Discussion Starter · #7 ·
imported post

I have considered locating the connector plug that runsto the radioand disconnecting it at the radio to see if the volume goes up? I don't know how much trouble this would be? Also, if the mute switch can be replaced, then there is a way to get into the box and look at the switch.The switch seems to be clicking in and out ok. I have worked it dozens of times with no result. Dennis
 

· Premium Member
Joined
·
4 Posts
Discussion Starter · #9 ·
imported post

You are right. I'll take the control box off the bike and look inside. If I can't get the switch to work, I'll think about removing the wire to it or buy a new switch.Can't be that complex, however no bike shop wants towork on it. Later, Dennis
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top