Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Premium Member
Joined
·
142 Posts
Discussion Starter #1
imported post

Is there a good way to get in the case and lube the inside of this thing? It has always been wrong on the speed but a gps solved that problem but yesterday it started squealing loudly. Any ideas?????
 

·
Premium Member
Joined
·
4,401 Posts
imported post

Nope, solid state. Probably need to grease the cable and hope that solves the noise. If not, you'll need to find a new speedo..
 

·
Premium Member
Joined
·
142 Posts
Discussion Starter #3
imported post

I already greased the cable about 2 weeks ago. It doesn't really sound like a dry cable this was a high pitched squeal. Got a good source on replacement heads?
 

·
Premium Member
Joined
·
1,299 Posts
imported post

ebay
 

·
Premium Member
Joined
·
503 Posts
imported post

you may want to replace cable. my 82 1100 done that and i replaced cable that done the trick.(but you can take it off from both ends and turn it.after i replaced mine.i pulled cable out of the houseing and cleand houseing with brake clean now it turns free so now i have a back up:D:D
 

·
Premium Member
Joined
·
142 Posts
Discussion Starter #6
imported post

My tach cable broke last year so I replaced both tach and speedo cables. I try and grease them at least twice a year. Not saying that a new one won't fix it may have to buy more dang it. thanks for input though
 

·
Premium Member
Joined
·
40 Posts
imported post

My speedometer started the same thing, I dissconected the cable from the back of the speedo head and noise was gone and I noted an increase in power right away.
I them removed the speedo head and turned it upside down and added a few drops of 10-30 engine oil where the cable connects and them spun the part that the cable drives a few dozen turns. reinstalled and presto no more noise, that was last Aug, Had the bike out yesterday for a 20km ride, still no noise.
hope this works for you, Shimmy.:dude:
 

·
Premium Member
Joined
·
142 Posts
Discussion Starter #8
imported post

Thanks all for the inputs but I think I have the problem solved, the new one should be here by friday or so. Found one on ebay
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top