Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Premium Member
Joined
·
2 Posts
Discussion Starter #1
imported post

2001 1800 Switches on theright control unit will not disengage once depressed. First the Reverse switch, and now the cruise control. Also the Start switch on top of the unit seems sensitive and sometimes takes several attempts to make proper contact to start the bike.I've sprayed super lubricant and cleaner into the unit and that hasn't worked. :(
 

·
Administrator
02 GL1800 w/Auto Pilot
Joined
·
59,722 Posts
imported post

Our 1800 GURUs will be along pretty soon with your answers.

Welcome to our forum and come back often.

Would you mind going over to the New Members forum and making an introduction there?
 

·
Premium Member
Joined
·
4,608 Posts
imported post

Sounds to me like corroded contacts and or connector blocks. You are in a humid area? I like CRC contact cleaner followed by CRC Super silicone spray. Hope you find out whatsup. jimsjinx
 

·
Premium Member
Joined
·
261 Posts
imported post

Some good plastic safe contact cleaner followed by silicone lube will usually do the trick. Some times it just takes several tries. Good luck and Welcome!:waving:
 

·
Premium Member
Joined
·
2 Posts
Discussion Starter #5
imported post

Can't really call Seattle Washington Humid, but you can certainly call it wet.. I'll try the CRC product and see if that helps, Thanks
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top