Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Itinerant Wing Preacher
Joined
·
875 Posts
Discussion Starter #1
imported post

Thanks for all of your responses.

Saddle bag adjusted Now opens fine.

Seat has been off repeatedly.

I think the accessory problem is the IGN switch. If you give the key a wiggle every thing comes on. Judging by the schematic I can replace the bottom of the switch. Doesn't look fun but not impossible.

Now the handle bar control to change the radio station will not work, and the mute button will not cut off the mute icon in the dash. The CB controls seem to work, but we do not have any headsets to test it with.

The cruise on light in the panel doesnt function, but the cruise works.

Jay
 

·
Premium Member
Joined
·
6 Posts
imported post

The ignition switch is easier to work on with the faring out of the way. You can have the faring on a GL1500 off in less than 45 minutes, it's not hard to do.
 

·
Premium Member
Joined
·
8,524 Posts
imported post

While you are taking this puppy apart, check and re-check your grounds. I get the impression that it might be ground related as well.
 

·
Itinerant Wing Preacher
Joined
·
875 Posts
Discussion Starter #5
imported post

Yes it is a 1500, my dad had to replace the 1100, I bought it from him.
 

·
Disfunctional Nimatode
Joined
·
3,381 Posts
imported post

I'd try some Radio Shack switch Cleaner/lubricant first. Some of the switches on my bike were funky when I first got her. Treated and worked everything over and all my switches have returned to very good operating order. Ignition switch TOO.
 

·
Premium Member
Joined
·
725 Posts
imported post

Big Port Jimmy 6 wrote:
Thanks for all of your responses.
 
Saddle bag adjusted  Now opens fine.
 
Seat has been off repeatedly.

I think the accessory problem is the IGN switch. If you give the key a wiggle every thing comes on.  Judging by the schematic I can replace the bottom of the switch. Doesn't look fun but not impossible.

Now the handle bar control to change the radio station will not work, and the mute button will not cut off the mute icon in the dash.  The CB controls seem to work, but we do not have any headsets to test it with.

The cruise on light in the panel doesnt function, but the cruise works.

Jay
i have the same mute issue. i thumped the radio in the upper right corner.poof it goes away.i suspect a loose solder connection in the radio.can you say Sierra Electronics???
 

·
Premium Member
Joined
·
151 Posts
imported post

Rudy has a post in his Technical pages about the GW ignition switch. Don't know if applicable to you particualr unit or not. Good Luck and welcome to the forum from the Buckeye State!
 

·
Premium Member
Joined
·
83 Posts
imported post

For the cruise on light not function, please check the bulb. I've recently changed my OD bulb, now works fine.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top