Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 16 of 16 Posts

·
Premium Member
Joined
·
104 Posts
Discussion Starter #1
imported post

Hi All, there is a volt/temp lcd gauge mounted on my 93 1500 SE. When I turn key on it shows like -14 degrees and o volts. Will stay on for a few seconds then go off. Still has back light on but no numbers. Anyone have any ideas on this? Thanks



CR
 

·
Premium Member
Joined
·
3,809 Posts
imported post

You don't give very much information. Where is it mounted on your GL1500? What does it look like......any pictures?

Is it mounted where the Gold Wing emblem would be on the ignition switch panel?

Does it have two small pin-type switches that you can push down to change modes?

Check your negative battery terminal, is there a "shunt" attached to it?

This would be a small square block with two terminals/bolts on it. There would also be three other small wires attached to it. This would be the shunt and it would be mounted "in series" between the negative battery cable and the negative battery terminal.

I am describing an Amp-U-Tron "amp/volt/temperature" digital meter that was made by Kriss Electronics. These were marketed during the 1990's and up until around 2002.

Just one possibility and there are more..............

Again, need more information if you want help.
 

·
Premium Member
Joined
·
104 Posts
Discussion Starter #3
imported post

Sorry for lack of info. It is Honda made and 2" x 3" mounted on right side in fairing pocket cover. Has outside temp on top and volts on bottom. 3 wires coming out and connecting to bike. It worked one day then it would only do the stay on for few seconds. I will take a picture when I get home.



CR
 

Attachments

·
Premium Member
Joined
·
3,809 Posts
imported post

I would follow the three wires and check the connections. If good, then it is probably the display unit has failed.
 

·
Premium Member
Joined
·
389 Posts
imported post

LOOKS PRETTY GOOD, WHERE DO I GET ONE OF THOSE???
 

·
Premium Member
Joined
·
63 Posts
imported post

looks real good, i'm itereseted in one also, let us know where you found it. and after we get ours hookedup we can tell ya what problem we are having.
 

·
Monkey with a Football
Joined
·
19,237 Posts
imported post

cloudrider wrote:
Sorry for lack of info. It is Honda made and 2" x 3" mounted on right side in fairing pocket cover. Has outside temp on top and volts on bottom. 3 wires coming out and connecting to bike. It worked one day then it would only do the stay on for few seconds. I will take a picture when I get home.



CR
I'll take a look at it for you if you want to ride it down here to Woodstock.
 

·
Premium Member
Joined
·
104 Posts
Discussion Starter #8
imported post

It came on bike. I have no clue where it came from other then its branded Honda.



CR
 

·
Premium Member
Joined
·
404 Posts
imported post

I want one of those as well. If anyone finds out where they are marketed, let us all know.
 

·
Premium Member
Joined
·
269 Posts
imported post

Hi where di you get the classic wings rider embelm?
 
1 - 16 of 16 Posts
Status
Not open for further replies.
Top